Scheduled FIRST Dashboard Maintenance
Scheduled for June 20, 2022 at 17:00 – June 23, 2022 at 15:35
Affects
Dashboard
Under maintenance from 5:00 PM to 3:35 PM
Completed
June 23, 2022 at 15:35Completed
June 23, 2022 at 15:35Maintenance has completed successfully.
In progress
June 20, 2022 at 17:00In progress
June 20, 2022 at 17:00Maintenance is now in progress.
Planned
June 20, 2022 at 17:00Planned
June 20, 2022 at 17:00The FIRST® registration system and dashboard will be undergoing scheduled maintenance from Jun 20-23.